Independent Renault Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello there!

Just purchased a Laguna 2 extreme 1.9dci 2003 53 plate with 62,000 miles. Full dealer history etc. The clutch pedal squeaks every time. The clutch seems fine - no juddering, smooth pulling off and accelerates nicely in 5th gear at 25mph without any slipping. Any ideas?

Thanks - great web site!
 

·
Premium Member
Joined
·
179 Posts
Hi mine does the same apparently it is the return spring attached to he pedal, it needs to be lubricated with something.
 

·
Premium Member
Joined
·
154 Posts
I had this after a master cylinder replacement, and and the springs were very well lubed with grease. In the end I sprayed WD40 on it and it's fine, I think it was metal to metal causing it rather than a spring - so annoying though particularly when there's no other rattles, buzzing, creaking or squeaks - it drove me absolutley mad because it was intermittent as well, and Renault were useless, they wanted me to book it back in for them to sort it out!!! :crazy: Never again will I have any recall work done if I'm not experiencing the problem myself, it was fine before they 'fixed' it, lol.
 

·
Premium Member
Joined
·
2,710 Posts
We had the same after our "recall" for the clutch as well.
Just put a bit of grease around the spring, cured it for a few weeks, squeak came back, so I put a bit more grease on it and squeak has completley gone!
 

·
Registered
Joined
·
35 Posts
this happened to my clio when it had been raining or the air was damp.
Just put some grease on the clutch pedal return spring and what looks like a plastic bearing the pedal pivot bolt goes through. I have this sneaky suspition that it was the plastic bearing, as I have never (touch wood ) had this problem since.
 
1 - 8 of 8 Posts
Top