Independent Renault Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
Morning all,

Seem to be having a funny problem with my renault at present.

Normal town driving seems fine, everything works as it should, however when i get onto the motorway it all changes.

As i get up to 70 and cruise for a while, the turbo seems to cut out completely. So theres just no power from it once this happens. This is rectified by turning the car on and off once stopped. Then up to 70 again and it happens again.

Have been getting a check ignition light come up the past couple of days, but the turbo issue has been going on for the last week or so.

Any advice? I was thinking electrics as it resets once car is restarted.

Thanks

Andrew
 

·
Registered
Joined
·
9 Posts
I think you need to pull some diagnostic error codes out of your car to get some more help.

There can be many things wrong when "check engine light" comes on and set your car in to limp mode = which normally restricts engine power in several ways like rpm limit, completely shut off boost pressure, and on (it's a bit different on every car model and manufacture how they do it)
Not saying its not a turbo fault but even if so an code can narrow it down for you.

Chris
 

·
Tartan terrorist in a dress..
Joined
·
22,793 Posts
Why are you saying turbo issues ? are you sure car isn't just going into limp mode? as said I think you need a diagnostic check before throwing money by playing parts darts
 

·
Registered
Joined
·
38 Posts
Discussion Starter #5
I had it to the garage and they diagnosed that the egr wasnt working well, even after cleaning. Unfortunately it has been changed and still not working correctly. Garage has said the the ecu has rejected the update so will need doing again. In the mean time its thrown up the engine man light and after ive scanned it, its given me a P0409 code for the egr. Hopefully i can get this sorted soon.
 
1 - 5 of 5 Posts
Top