Independent Renault Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Does anybody know how to improve the reception on the standard laguna ph1 radio. I find that I can barely get the main fm stations and the mw stations tend to hiss alot. The cd player works fine and I cannot see an aerial. I do have a newer laguna an it works fine.
 

·
RIP 31-12-2008
Joined
·
5,807 Posts
Hi there David, What year is your Lag I as the ''Phase 2'' or facelift model has the aerial embedded in the rear screen whereas the pre 98 job has a roof aerial mounted just in front of the sunroof,
Regards Leroy
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
laguna radio

Its a phase 2 'facelift model' Last of the rounded shaped lagunas.
I think the aerial is in the back somewhere but can't find it to sort out the problem.
 

·
RIP 31-12-2008
Joined
·
5,807 Posts
Hi again, I'm pretty sure the aerial is in the rear windscreen on the phase two, when you lift the hatch you should see the rubber cable sheath coming out from under the roof lining, which I presume houses the wiring for the heated rear screen and the aerial. I'll have a look at mine tomorrow and get back to you,
Regards Leroy
 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
cheers leroy. Just got heating fixed (new pollen filter so easy i must be dumb). I'd like to fix the radio next. Had a Laguna II 1.9dci just got rid and kept the older and much much better laguna 1.9 dti. Just gotta fix the radio and I'll be well happy. Car has been to france 4 times and never give a problem. Tokk newer car to cornwall last year and it was a night mare. Dashboard like a disco at one point. Fixed under used warranty luckily. Older is better. Oh I mean from N.Ireland to the south of france.
 

·
Premium Member
Joined
·
669 Posts
Hi David, it may be worth just popping the head unit out and confirming the arial is connected fully, save all the hassle removing trim etc.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #8
Thanks for the idea fig_jam_uk. I got the head unit out and the aerial was well connected. Gonna have to try something else. Just hope someone else has had the same problem and fixed it.
 

·
RIP 31-12-2008
Joined
·
5,807 Posts
Hi again David, sorry I didn't get back to you earlier, I called
in to the local Renault dealers at Warsash to pick up a new oil filterand the guy there seemed to think, after a bit of head scratching, that the aerial is in the rear screen on the facelift model. Just a thought though, is the heated rear screen working okay on your car? I almost bought a newer Lag too but like you I've been to SW France a couple of times in mine and also had no problems, off there again at the end of June. Hope you get your problem sorted.
Regards Leroy
 
1 - 9 of 9 Posts
Top