Independent Renault Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
:confused: The blower on my car has stopped working!

The display appears to be ok-well it is lit up and all the buttons work.

But the fan does not appear to be blowing no matter how many bars I have it on.

I have taken the unit out to check for a loose wire,but this unit appears to be 2nd hand as it has LAGUNA 2003 wrote on it.

Am I doomed to replace the entire unit or is there a fuse or relay I can check.

Is there a simple way to check power to the heater fan?

Any help would be great...
 

·
Premium Member
Joined
·
18,909 Posts
Hi yes there is a fuse and relay not sure where but iam sure someone will help soon or try a search to see what comes up hope this helps

Sorry if you have a circuit tester see if power is getting to the motor???if yes its the motor again i believe there a sore point for renault whats new!!!
 

·
Registered
Joined
·
33 Posts
Just Changed my pollen filter,
If you take the glove box out , just held in with 1 screw and pulls out as its just clipped in. You will then beable to see the blower motor and to the left there is a pannel with a couple of relays and fuses may be these ? not sure but worth having a look.

Gary
 

·
Registered
Joined
·
32 Posts
Discussion Starter #6
HI ALL

Checked relay+fuses all ok.Traced problem to a bad connection on the blower motor plug.

SH*TY French elecrics!!!

Thanks for the help.

I would be interested in the cost for a replacement pollen filter:)

regards
 
1 - 8 of 8 Posts
Top