Independent Renault Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi,

The trip computer on my 1.8 Privilege only shows functions related to distance - e.g. mileage and average speed. But if I select a fuel function like MPG I just get a flashing '- - -'. I have tried to reset the computer by holding the button and inserting the keycard but that did not help. Is there one sensor that might need replacing?
As always any help would be most appreciated
Thanks
Peter
 

·
Premium Member
Joined
·
2,710 Posts
It takes a while for the average mpg display to display anything. WHen you reset it you do get ---- for a few miles until it starts to work out an average.
If after several miles you are still getting this display then it would point to either a faulty computer or possible a sensor.
It is very difficult to tell exactly. If you can live without it and your car is out of warranty I wouldn't bother. A new display panel is approx £500 from Renault!
 

·
Premium Member
Joined
·
6,475 Posts
I had this happen to one of my Laguna 1's when it had the battery off for a week while the gearbox was rebuilt. All of the fuel related functions went blank.

One dealer quoted me 500 quid for a new panel. The car was subsequently sold, and the new owner got the panel reset by a different dealer for next to nothing.

Did the dash actually go into diagnostic mode when you tried to reset it? The dials should step up and down if you've got it right. Repeatedly pressing the same button will go through various displays, and pressing the trip reset button should put the dash back into normal operating mode.

Beyond that, try asking around a few dealers. The 'reverting to Km' problem is different and cannot be fixed. This one possibly can, depending on who you speak to.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
Laguna II trip computer

Hi,

Thanks for the reply. The panel did step through the speedos like you said in the reset mode. If it's £500 for a new one I'll certainly do without it but that price doesn't surprise me after being charged £140 for a tyre valve on my previous Laguna!

Thanks again

Peter
 

·
Registered
Joined
·
54 Posts
A local independant recently fixed this for me (while using his magic box to diagnose another fault).
If I understand correctly, the instrument panel calculates mpg etc based on inputs from the ecu (fuel flow and distance travelled).
The diagnostic of the instrument panel reported "no fuel signal" (from ecu).
A check of the ecu showed it working in Km. Changing this back to miles did a reset of the ecu and fixed the problem.
Bottom line is that it needed someone with a diagnostic computer to reset it; the independant cost me £25; Renault price £75 + vat minimum!!!

Cheers
Andy
 
1 - 5 of 5 Posts
Top