Independent Renault Forums banner

1 - 20 of 21 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #1
hi i have been given a megan but elec rear windows are not working. iv checked fuses and ok. just wondering if anyone any ideas befor i start taking door apart to investigate.
thanks in advance
 

·
Super fantastic Mod Technical Supremo Nice Guy
Joined
·
37,707 Posts
Did both stop at the same time, or?
 

·
Technical Supremo, Platinum, I let the Dogs out
Joined
·
6,986 Posts
is this just from the drivers multi switch control or from each rear doors own switch as well?
 

·
Technical Supremo, Platinum, I let the Dogs out
Joined
·
6,986 Posts
can you tell us a bit more about your car now then, age / fuel/ engine size etc so we can get the correct diagrams up and have a look
 

·
Super fantastic Mod Technical Supremo Nice Guy
Joined
·
37,707 Posts
Can you ask the mate who gave it you

On your drivers side switching unit, should be a switch for rear windows ,, just behind the rear switches, press this, see if you can hear a click.
No click, take this out/unplug ,,, and try your rear switches again..
 

·
Registered
Joined
·
44 Posts
Discussion Starter #9
Can you ask the mate who gave it you

On your drivers side switching unit, should be a switch for rear windows ,, just behind the rear switches, press this, see if you can hear a
click.
No click, take this out/unplug ,,, and try your rear switches again..
Thanks for reply I will try that when back off holiday in 10 days as car is at home
Thanks again
 

·
Registered
Joined
·
44 Posts
Discussion Starter #10
hi i have been given a megan but elec rear windows are not working. iv checked fuses and ok. just wondering if anyone any ideas befor i start taking door apart to investigate.
thanks in advance
Can you ask the mate who gave it you

On your drivers side switching unit, should be a switch for rear windows ,, just behind the rear switches, press this, see if you can hear a
click.
No click, take this out/unplug ,,, and try your rear switches again..
Thanks for reply I will try that when back off holiday in 10 days as car is at home
Thanks again
Iv tried switch on drivers door and it clicks but still no movement on rear Windows. Tried removing switch and disconnected but still same.
Thanks for your patience
 

·
Super fantastic Mod Technical Supremo Nice Guy
Joined
·
37,707 Posts
Should still have movement of rear windows even with no switch in place, from THE front control switch, if it was that..
Its door cards off time now then..
Need to check/inspect if its temics, or something else, but either way, you need to get at the wiring ..
 

·
Registered
Joined
·
44 Posts
Discussion Starter #12
UOTE=ours2012;4207093]Should still have movement of rear windows even with no switch in place, from THE front control switch, if it was that..
Its door cards off time now then..
Need to check/inspect if its temics, or something else, but either way, you need to get at the wiring ..[/QUOTE]
 

·
Registered
Joined
·
44 Posts
Discussion Starter #13
Have managed to get fuse box 1 lowered by drivers dash found blown 7amp on top side of fuse box lowm. Replaced still no wubsow movement
 

·
Premium Member
Joined
·
172 Posts
I agree with ours2012 - get the rear cards off and check the black temic controllers. Particularly check for any signs of melting on the power supply connectors (something that happens often), if there is none it's likely the temic unit. Also, be aware that when there is an issue with one of the windows a lot of garages will 'make safe' by unplugging both rear windows.

Failing that, does the Megane share the 'under passenger seat' connector?
 

·
Super fantastic Mod Technical Supremo Nice Guy
Joined
·
37,707 Posts
No under passenger compartment..
To get the door cards off, without damaging them, its back seat base out, then you can get at the push in plastic clips. once off, you can then get at the rear door switches,, as these dont like to come out from the front easily ..

Once off, put your hand down and just move the temic backwards and forwards ( the temic is held on by a small torx screw, so dont try pulling the temic off, without removing this screw,) but a slight movement of the temic, might help here...
 

·
Registered
Joined
·
44 Posts
Discussion Starter #16
thanks for ideas everyone may i just point out my car is a laguna not a megan dont know how i made that mistake when putting on here. iv removed fusebox drivers side (fusebox 2) and found the fuses hidden be hind (stupid place). a 7.5 fuse had blown . replaced and still no joy on rear windows. checked all fuses under bonnet well which i can see.
please please any other things i can try. old owner said they were not working when he had it so cant help
thanks again in advance
 

·
Super fantastic Mod Technical Supremo Nice Guy
Joined
·
37,707 Posts
Ah we are giving info for a megane,,
Lets try again, year of car, engine size.. or picture of oval plate..
Just cover the VIN if using oval plate way..

This car, going to ask now, right hand drive, As fuse box layout is upside down on a left hooker
 

·
Super fantastic Mod Technical Supremo Nice Guy
Joined
·
37,707 Posts
Going to struggle until tomorrow to answer you with any certainty ..
Have some info in front on this laptop..
But cannot cross-reference over, to check if the diagrams are correct,
Will have a look tomorrow and let you know..

And its both rear windows not working, just to be sure here...
 
1 - 20 of 21 Posts
Top