Independent Renault Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello people, Id appreciate any help or guidance on the following please.
I have had a 2005 Megane II 190dci for acouple of years now, the "check Injection" & "service" lights showing on and off for 3 months now, losing power when their on, ive had three differant valves/filters fitted and at one point even bypassed one which restored the power even when the lights were showing. A couple of days before it was due to go into the garage the lights went out, the bypass was removed and normal service was restored.
Recently the Air bag light came on along with the service light and on occasion the check ingjection light would accompany them but would go off after a couple on minutes. I took it in for a service (it has been serviced regularly since ive had it now showing 92000 miles, the air bag and service lights have stayed on and the day after the service the Toxic fume filter light has joined them.
The car itself is running fine, no stutter or misfiring the garage has had the diagnostics looked at the computer cleared/reset. If anyone can throw any light on the above please get intouch.
Regards Paul
 

·
Premium Member
Joined
·
43,291 Posts
For either warning light to illuminate the ECU has to have recorded a fault.

Having the ECU read by a Renault compatible code reader should show what faults have been stored.

One of the most common causes of an air-nag warning is down to poor connections under either of the front seats so it may be worth exploring that aspect.:)
 
1 - 2 of 2 Posts
Top