Independent Renault Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
hi guys i have a 2000 megane cabrio 1.6 16v resently changed thermostat as it overheated now the temprature goes throught the roof then quickly drops to below half once this has hapened it goes to just under red then back to under half constantly fan cuts in and works fine have flushed it and bled it many times so dont think its an air lock could it be the waterpump
 
D

·
Guest
Joined
·
0 Posts
Could be the water pump and sounds highly likely with the symptoms you have.
 

·
Premium Member
Joined
·
122 Posts
Sounds to me like either an air lock or incorrect / faulty thermostat. Meganes can be a bu**er to bleed especially if the ground you're on isn't level.
 
R

·
Guest
Joined
·
0 Posts
Sounds like a faulty thermostat to me? to establish I would take out the thermostat and see what happens to the engine temperature then if all else is well it should run on the cool side.
 
R

·
Guest
Joined
·
0 Posts
Or - the coolant temperature sensor may be U/S.
I had this problem on a 2.0 Scenic last week the temperature sender was faulty the temperature dial was showing the car was much hotter than it really was making the radiator fan cut in a run sooner than it should and it kept running. The thermostat then wasn't opening as the top radiator remained cold.

I changed the temperature sender and everything then worked properly though the heater circuit was working properly before and after.
 
1 - 8 of 8 Posts
Top