Independent Renault Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
A couple of months ago I noticed that the air con on my 2007 Megane was not blowing cold air. I booked it in at my local Renault specialist to have the air con system fully serviced. They drained, regassed and checked the tightness of the air con and reportedly found no leaks.
At first all was well and ice cold air was coming from the vents when the air con was switched on. I turned the air con on today and noticed the air was not ice cold as it should be.
Normally when you press the air con switch you can here the compressor kick in but now it won't. Is this due to lack of pressure?
Any ideas as to whats causing this?:(
 

·
Registered
Joined
·
9 Posts
My guess is, if the air-con is working intermittently, it might not be the gas pressure issue.. it could be some relay or contact problem. Either a faulty relay that turns the compressor on or off or some bad connectors.. my take in this is to ask the mechanic to clean all electrical contacts pertaining to air-con system and if problem persist, replace the relay..
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Just a quick update on my on going air con saga.
Have had my local Renault specialist reinspect the system and found it to be empty of gas. They have carryed out a uv test, no faults found. They have reinjected new dye, flushed the system and rechecked, no faults found. They have carryed out a nitrogen test and no leaks have been found!
The garage seems to think the gas may be leaking from the radiator. Could this be the reason as to why the gas is escaping?
Any advise would be appreciated, thanks.:confused:
 

·
Premium Member
Joined
·
24,215 Posts
If the refridgerant was escaping anyhwere either a pressure or vacuuum test should reveal if there is a leak in the system. In other words if there is a leak then the system won't hold either pressure or a vacuum.
Yes it is possible the radiator (condensor) is holed but the above tests should still reveal if there is a leak.
 

·
Registered
Joined
·
47 Posts
The condensor is the most likely cause of the leak. As madnoel10 says a pressure test (nitrogen test) ought to show it up, having said that some leaks are very small and difficult to spot without very sensitive test equipment. The fact they are using uv dye indicates they are not upto date with leak test technology.

Not what you probably want to hear, but see if you can find a company that uses a "sniffer", literally samples the air around the system and reacts to refrigerant. Using a sniffer and 150 to 180 psi nitrogen pressure ought to show where the leak is.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #7 ·
Why does my Megane Air Con keep breaking?

This is an on going issue this one and it's one that is trying my patience.
Two weeks ago my local independant renault specialist seemed to have finally diognosed why my a/c wasn't working. Answer: it was leaking gas from the condenser and a/c pressure switch.
So, a new condenser has been fitted along with a new pressure switch. They then regassed the system, made sure there was no leaks and everything was working as it should.
But, once again the air coming from the vents when the a/c is switched on is not ice cold.
I'm at a loss as to why it keeps failing.
The work stated above cost £378!!
I'm a bit annoyed that I have payed alot of money for something that has not been fixed!
Has anyone any ideas as to why my air con persistantly keeps breaking???
 

·
Registered
Joined
·
9 Posts
Hi. air not getting cold could be due the the same leak problem, gas not charged to right pressure, faulty pressure switch, dirty filter drier, faulty condenser fan, faulty compressor, clogged air filter, faulty a/c switch...its quite impossible to tell u the remedy unless you have the pressure gauges and some knowledege of what to see, where to see and what to feel and where to feel.

Easier thing to do is just go to at least 3 diff workshops to ask them check and find the similarities and differences.
 

·
Registered
Joined
·
1 Posts
Hi,
I have an 2010 Megnne expression dci. I have a constant sick/wet dog damp smell which I think is comming from the air con unit. At the service last week i paid for a 'bomb' to go through the unit but the smell was back after two days. The garage tell me the air con unit is ok and is not covered on the warranty. Has anyone else had a similar problem.
Thanks
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top