Independent Renault Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1 (Edited)
can anyone help?
the thermostat gave up on my megane and caused overheating and a loss of power. it would still turn over so no seize issue, and there was a knocking sound. i have since had the head off and skimmed, new thermostat,new gasket, and put back together but im getting a rattle noise at the top end and occurs from 1500-1750rpm upwards. it sounds like it comes from the inlet manifold or pos injection, but this should have been unaffected. the timing belt was replaced and is spot on. any ideas any one?
any help would be appreciated.
paul
 

·
Premium Member
Joined
·
14,145 Posts
Hello & Welcome to the Forums Paul.

I'm sure someone will be able to assist with your post shortly.

Regards

Ottoman
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
yeah the engine runs ok, it ticks over,but the revs do rise and fall and the tappets have correct clearances according to haynes. at first the tappets where slightly out but i sorted that and the noise is still evident.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
hi, i dont think so, all the timing marks are very clear and all line up ok.
if it was only one tooth out, would this cause the noise im getting. ile have a good look later today to double check but im pretty sure its fine.
 

·
Registered
Joined
·
92 Posts
How does it rev? Usually if there's a timing problem it will rev really bad up to around 2.5k revs and then seem fine after that. I've done loads of timing belts and sometimes it is quite hard to get it spot on, especially if it's a twin cam, or more:eek:
 

·
Registered
Joined
·
10 Posts
Discussion Starter #8
it revs fine, perhaps a bit of a delay after opening the throttle but im sure it did that before anyway. the noise im getting does sound directly related to engine speed though.
 

·
Registered
Joined
·
92 Posts
Well without hearing it I really don't know what else it could be. It sounds like everything's as it should be, maybe it's a noisy injector or two? Sorry I can't help you any more matey, hope you get it sorted soon:)
 
1 - 12 of 12 Posts
Top