Independent Renault Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
I have a 2001 Megane series I and 2 months ago the engine mgt light came on, my local garage & auto electrician first diagnosed the oxygen sensor, then the 'carbon container', then a rogue battery cell and has replaced these parts over the last few weeks with genuine Renault parts. On each occasion the light stays off for about 30 minutes then comes back on ! ... any ideas ?

One other point, I can hear electrical interference on the radio a 'crack' noise related to the tickover of the engine - can this be related ? my garage thinks not.
 
A

·
Guest
Joined
·
0 Posts
Welcome to the forum

I do think that you should return the car back to them
advising them that you have been charged for repairs that have not been done and the problem remains.

Don't pay for another test, it should be up to them to detect the fault and advise you. try to recover some of your money you paid them it's not a good garage that cannot fault find. if needs be take it to another garage and then pass the bill onto the old garage.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5 (Edited)
All the coils have been changed within the last 9 months The car is running fine, we don't have any idea why the light should be on ! The garage resets the ecu but the light then comes back on after a period ranging from 30 mins to 48 hrs

I've just rung the garage about the fault codes and they are going to ring back soonish
 
1 - 5 of 5 Posts
Top