Independent Renault Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
The high level brake light on my clio is working, but not the 'main' brakelights.

I just checked the bulbs and both filaments appear intact (dark outside) as do the fuses.

The running lights are fine.

Any suggestions gratefully received.
 

·
Premium Member
Joined
·
1,094 Posts
Sometimes the bulb filaments look ok but don't always make good contact. I would change the bulbs 1st and then explore other things.

You'd be surprised at how many people drive around here with JUST the high level brake light working
 

·
Premium Member
Joined
·
334 Posts
Hi whilst there is a topic floating around about brake lights can i jump in! My wifes T reg RXE Clio has a third brake light which does not work, but the others do? Anyone know where to start checking? I know its not a legal requirement but the more brake lights the better!

Thanks
 

·
Premium Member
Joined
·
1,094 Posts
Hi whilst there is a topic floating around about brake lights can i jump in! My wifes T reg RXE Clio has a third brake light which does not work, but the others do? Anyone know where to start checking? I know its not a legal requirement but the more brake lights the better!

Thanks
Check the wiring connector - I don't think there is a seperate fuse for it, and I doubt all the bulbs would have blown at the same time (unless the last owner neglected it - I'd check the bulbs anyway)
 

·
Premium Member
Joined
·
334 Posts
Thanks for that will have a look this weekend and see what i find. Looks like its going to be nice and sunny so no doubt i will be asked to wash it for her!

By the way do must of us blokes wash our other halfs cars? I believe that if she drives through puddles they should wash them! Anyway what she doing out of the kitchen!!:rofl:
 
1 - 6 of 6 Posts
Top