Independent Renault Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1 (Edited)
I have a 51 plate Megane 1.9 dci, 97000 miles on clock.
Whilst driving down the motorway, the glow plug warning light came on, so i pulled into the slow lane as a precaution.
The car then started to lose power, luckily enough the services were only a couple of miles further on. By the time i got there, i was doing 30mph max.
I let it rest for 15 minutes, then started it up again, the warning light had gone out, but the power had gone. So pulled over again got the revs up a bit and tried to make the last 10 miles to work. I did a steady 50mph for 2 or 3 miles, then it just died again. It does'nt cut out, just loses power.
The RAC man could'nt diagnose the problem with the laptop as no faults showed up.
When i start the car up and hold the accelerator pedal down to the floor the revs go up to 2500 and stay there.
Could anybody help me with this?
Thanks.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
It was serviced last month, cant tell you when fuel filter was changed. I have drove it in limp mode before, should'nt the engine management stop light be on?
 

·
Registered
Joined
·
16 Posts
Discussion Starter #5
Thanks for that info, Madnoel, i will have a look into that.
Is the filter easy to change, or should it be booked in to the garage?
Cheers
 

·
Registered
Joined
·
16 Posts
Discussion Starter #6
Changed the Petrol filter, does'nt seem to be any different.
There are no warning lights showing, but still only gives me max 2500 revs.
 

·
Premium Member
Joined
·
43,291 Posts
Hi Liam - I take it you mean diesel filter - has the EGR valve been checked:) Does the engine always stop revving at 2500 or does it vary - if it is fixed it sounds like the car is in limp mode but not showing a service fault.:)
 

·
Registered
Joined
·
16 Posts
Discussion Starter #8
Hi Noel - I do mean Diesel filter, sorry bout that. Have'nt checked EGR valve yet, will have a look at that tomorrow.
The engine revs stay at 2500. Interestingly, when the diesel filter was changed it was the same, but we left it running for half an hour and tried it, It seemed normal, but after turning the car off, and coming back an hour later, it was back to 2500. Im thinking i may have to book it in.
Cheers.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #9
Took it to garage today, they diagnosed a faulty ERG valve.
I let them fit a new one, ouch. Took it for a spin on the motorway and it seems fine, fingers crossed.
Thanks for your help Madnoel.
 

·
Premium Member
Joined
·
43,291 Posts
Hope that sorts the problem Liam - yeh many on this forum are now of the opinion the EGR valave should be cleaned during a service. Personallly i think it EGR problems are exacerbated by the long service intervals.:)
 
1 - 10 of 10 Posts
Top