Independent Renault Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
I'm experiencing problems with the rear heated screen on my 98 Megane, in that it doesn't work!

I press the demist button, the light comes up on the display, I can hear the relay click, but nothing happens on the rear screen. Checked the fuse first, no problems there. Got out the multimeter, and there are no breaks in any of the lines on the screen.

What I did discover, however, is there is only just about 1 volt across the terminals that connect to the rear screen.

I haven't been able to find out what voltage should be present (12v?), but I'm assuming 1 volt is not enough

I want to check the relay, but can't find it. Haynes manual only mentions the relay in the wiring diagrams, but doesn't state it's output voltage, or where it's physically located.

I'm assuming it's somewhere behind the fusebox, but don't want to start pulling the car apart without knowing.

if someone could help me out with locating the relay, removing it, checking it, and finally where I can but a replacement(!), I'd be very grateful.

(Unless someone know a different reason the screen doesn't demist?)

Thanks in advance,

- Steve
 

·
Premium Member
Joined
·
136 Posts
Steve,

The heated rear screen relay should be located in the passenger compartment fusebox.

If the light on the display is illuminated when you press the demist button, then the relay has tripped in and is supplying 12 volts to both the light and the rear screen. If the display is illuminated, the relay is OK.

Therefore, you should have battery voltage at the rear screen.

I suggest you remove the tailgate trim panels and probe for voltage at the tailgate wiring connectors. Also check the earth connections very carefully.

Sam
 

·
Registered
Joined
·
11 Posts
Discussion Starter #5
Hi Sam,

Thanks for the response. What confuses me is that all the rear lights, and the rear washer and wiper are perfectly fine. It's only the heated screen that's faulty. If it was an earthing problem on the tailgate, Wouldn't all the electrics at the back be faulty?
 

·
Premium Member
Joined
·
136 Posts
Steve,

Remove the tailgate trim panel and find the feed to the heated rear window. With the heated window switched on, what voltage are you finding between the feed and a good earth?

This may be a break in the feed wire to the tailgate.

Sam
 
1 - 6 of 6 Posts
Top