Independent Renault Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi,

If anyone can help me it would be much appreciated as I'm on the verge of having to get rid of my beloved Megane Sport Tourer as the electrics are behaving very strangely indeed!

About 1 year ago I had an airbag warning light come on and every time I took the key card out and then put it back in the clock would zero and the radio would need the code putting in as if the battery had been disconnected.

I took it to an electrical specialist and got the steering collumn electrical unit replaced. This fixed the fault.

All that has changed since then is that I have had to replace a headlamp and indicator bulb and the car has the water leak problem into the front door side pockets (it has had this for years).

About 2 months ago the car suddenly started zeroing the clock and needing the code for the radio every time after you had stopped and taken the card out and then tried to start it again.

I took it to the same electrical specialist who changed the 20amp fuse that had blown.

However since then it keeps blowing this fuse on startup and more recently the whole dash went dead instead of just the clock and radio.

Also there is an intermittent fault with the electric windows where they only go up a few inches at a time.

My electrical guy is stumped as he can't get the car to consistently produce the fault and it is starting to cost a lot of cash!

Any ideas?
 

·
Registered
Joined
·
2 Posts
Jonny,

What happened in the end? I ask because I have got a strange intermittment fault on the front indicators of my Megane :-(

John D
 
1 - 2 of 2 Posts
Top