Independent Renault Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I own a 1.2 clio MTV limited edition. 2000 year. There appears to be a major problem with the electrical system and I am beginning to wonder if it is related to the ECU? Over the last month and 1/2 the car does not always start immediately and quite often takes 10 mins of turning the key for it to start.
Then only last weekend the engine cutout completely in the middle of the road and the engine management light was displayed. Although it would appear that the reason it cutout was due to failure of the timing belt. Despite having fixed the mechanical problem the Engine Management light is still displayed on the dash and there are problems with central locking and electrical windows also!

As it stands the engine will not turn over nor can the car be locked or the windows be used! It almost seems as if the engine immobiliser is engaged or something is wrong with the ECU...any ideas??
 

·
Let's be carefull out there
Joined
·
19,360 Posts
I believe I am right in saying that the engine management light doubles as the immobiliser light. If at all possible try to get the fault codes read and the ECU cleared. You could try disconnecting the battery for a few minutes to reset the ECU but I'm guessing it was disconnected during the repair so my money is still on the immo. There are a couple of links to immobiliser issues in the Clio FAQ under "Electronics" click the link in my signature for the FAQ
 
1 - 4 of 4 Posts
Top