Independent Renault Forums banner

1 - 20 of 33 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hello to Everyone on the forum,
My wife has a 1998 Clio 1.2RN, the newish shaped one (S reg). We went to Wales (from Kent) this weekend and halfway up the M40 the speedo went from reading 70 to 0. After about 5 mins of no reading a warning light came on the dash that looks like one of those life support machine readouts?? Then after another 10 mins the speedo read ok again and the warning light went out. This has happened on and off all weekend with the speedo and warning light (speedo zero, light on and vice versa) coming on and off with anything from 2 mins to an hour between changes. Everything else on the car works perfectly and it drove to Wales and back with this going on/off without a hitch. In Wales I took both front wheels off but couldn't see a sensor or cable or anything that I thought maybe loose or dirty or something. Could anybody suggest what could be up that maybe I could fix myself.
Thanks in advance for any help,
Steve.
 

·
Registered
Joined
·
6 Posts
I have exactly the same problem with my 1998 RXE 1600. I don't get any warning lights when the fault is present One thing that I did note is the fault only manifests itself when I have the heater on, so I presume there is a faulty connection to the speedo head or inside the unit. Mr "Haynes" says that any faulty units are not repairable except by replacement of the complete unit. I would be grateful if anyone can confirm that entry into the unit is impossible, otherwise I will remove the unit and repair any bad solder joint on the internal PCB.
 

·
Registered
Joined
·
3 Posts
renault clio speedo

I have the same problem... I used to work for renault I just asked my mate and he told me the fault is the pickup in the gearbox (this is a very common fault at between 70,000 & 100,000 miles)
The engine warning light comes on if the engine revs go above 3,000rpm for longer than 4mins with no info from the speedo
the pickup is located at the top of the gearbox casing to the right of the exhuast at the righthand corner of the cylinder head..it is a bit hard to spot..it has a little metal clip on shield if you give it a bit of a twist your speedo will start working again for a short period of time.

As yet I have not replaced the speedo pickup because I do tend to try and repair things if poss...if yuo wish to calculate your speed its easy as if you are in 5 gear your speed will be twice your revs i.e. 2000rpm = 40 mph
 

·
Registered
Joined
·
2 Posts
where to get the parts?

i have a clio rxe 1.6 and the speedo sensor has gone i have been told i can only get the parts directly from renault is this correct?

Thanks
 

·
Registered
Joined
·
3 Posts
speedo drive replacement

Hi There

Yes you can only get this from Renault, as far as I remember it cost me £40( 2 years ago now) you just have to give it a good hard pull and it will come out, if a garage do it for you dont pay over the odds it is a 10 minuter job. It was impossible to repair.

I have since sold the car and brought a Mitsubushi colt CZ1, soooooooo reliable 60 mpg goes like hell if u want it to and is such fun to drive.....where as the Clio was the most boring car I ever owned
 

·
Registered
Joined
·
3 Posts
the pickup is located at the top of the gearbox casing to the right of the exhuast at the righthand corner of the cylinder head..it is a bit hard to spot..it has a little metal clip on shield if you give it a bit of a twist your speedo may start working again for a short period of time.

To remove it it needs a sharpe hard straight yank
upwards
 

·
Still a Petrolhead but also like diesel
Joined
·
2,311 Posts
Do a search on the forums, there are instructions and pic's of what the sender looks like ... take care though as the Clio2 has two types of sender, the both look the same but one is a push fit and the other is held in place using a screwed on horseshoe collar .... if its the latter and you just pull it may well break .... use a torch to check it before pulling.

Hope it helps :)
 

·
Registered
Joined
·
15 Posts
Re: Renault Clio 2 - Speedo Not Working

Just chaged the speedo sensor on the Clio. An easy job with no tools required albeit access tight.
Old one would work intermittantly.
Carefully cut top to open up old one, one moving part and a little printed circuit inside. Inside top was quite oily so perhaps that was affecting the detector on the circuit board picking up a signal from the turning part?
With a good clean and sticking top back on could probably reuse old one but new part was only £21 so didn't break the bank
Peter
 

·
Registered
Joined
·
15 Posts
Re: Renault Clio 2 - Speedo Not Working

Been thinking a bit more about why sensor was only working intermitantly.
Not a problem with water getting into connection block as was like new.
Heat from exhuast didn't seem to be the issue as heat shield still in place.
Circuit board inside also looks as new
Only thing was that there was a fair bit of black gearbox oil up in top of unit. Perhaps over the years probably gets a bit stickier and doesn't all run back down into gearbox and builds up and affects sensor

If someone has same simptoms may be possible to flush out oil by taking off unit from car, turning it up side down and pouring in some white spirits, spinning around shaft by hand or with a drill and draining off fluid that should have thinned out oil.
Anyone done this or fancy giving it a try?
Here is picture of inside unit

IMG_0056 (Small).JPG
 

·
Registered
Joined
·
1 Posts
Re: Renault Clio 2 - Speedo Not Working

hi! I have the exact same problem, and I did exactly what you said to do with the white spirits and it helps for a littel bit and then the speedo stoped again.
could you please post pictures of the speedo from the top of it so I can see the sensor, and if someone have a better idea please let me know before I buy a new one.
also if someone finds that speedo on ebay please send me the link cause I didn't find it there
thanks
hagash.
 

·
Premium Member
Joined
·
2,299 Posts
Re: Renault Clio 2 - Speedo Not Working

hi guys,

currently trying to change the speedo sensor on a 1998 clio, and its not happening for me:crazy:

ive tried to push in the 2 securing 'lugs' and pull the sensor at the same time but it wont move at all. doesnt appear to be anything else holding it. ive read the FAQ pages and it appears you dont need to do anything other than pull the sensor? this definetly isnt working for me at the moment.

can anyone advise?

many thanks
stef
 

·
Registered
Joined
·
15 Posts
Re: Renault Clio 2 - Speedo Not Working

hi! I have the exact same problem, and I did exactly what you said to do with the white spirits and it helps for a littel bit and then the speedo stoped again.
could you please post pictures of the speedo from the top of it so I can see the sensor, and if someone have a better idea please let me know before I buy a new one.
also if someone finds that speedo on ebay please send me the link cause I didn't find it there
thanks
hagash.
The long stem that turns has a metal or graphite ring set into the top, This ring is magnetic.There is a sensor on the little circuit board and the spinning magnet must generate a voltage that by the magic of electronics gives a speed in proprtion to the spinning. Or I could be completely wrong!
Camera not good enough to take a clear picture.

I bought mine from Euro Parts
 

·
Registered
Joined
·
15 Posts
Re: Renault Clio 2 - Speedo Not Working

hi guys,

currently trying to change the speedo sensor on a 1998 clio, and its not happening for me:crazy:

ive tried to push in the 2 securing 'lugs' and pull the sensor at the same time but it wont move at all. doesnt appear to be anything else holding it. ive read the FAQ pages and it appears you dont need to do anything other than pull the sensor? this definetly isnt working for me at the moment.

can anyone advise?

many thanks
stef
I can only advise on the 1999 Clio that I changed to sensor on it did indeed just pull out. At first didnt want to yank too hard as wasn't sure if there were any lugs but there weren't and out it came
The only lugs holding it are on the unit but were below opening and just bend in when you pull the sensor out.
Peter
 

·
Premium Member
Joined
·
2,299 Posts
Re: Renault Clio 2 - Speedo Not Working

I can only advise on the 1999 Clio that I changed to sensor on it did indeed just pull out. At first didnt want to yank too hard as wasn't sure if there were any lugs but there weren't and out it came
The only lugs holding it are on the unit but were below opening and just bend in when you pull the sensor out.
Peter
hi,
thanks for the reply.

i finally got the sensor out in the end, a big screwdriver and a very swift whack with a hammer! was a last resort but it worked:rofl:
fitted the new one...no effect so i pulled it out - very easily i might add. but i found a break in the wire that had been hidden but someone had tried to solder it before and made a very bad job of it so i cut the bad section out and crimped it back together with a new piece of wire but still nothing. whats the chances of a new sensor thats duff?

i checked between terminals before ordering the sensor during the week to make sure there was power and an earth to the sensor but i didnt check the signal wire so i will need to trace this back to the ecu? and see if i have continuity, im hoping its just a bad wire so i can replace it if need be and thats it end of but who knows.

does anyone know if its possible to do a self check thing on the dials? my clio used to do it but i had to hold the computer button on the end of the stalk which this clio doesnt have...

cheers
stef
 

·
Premium Member
Joined
·
2,299 Posts
Re: Renault Clio 2 - Speedo Not Working

hi all,

well i had another look at the clio speedo fault tonight, still no further forward really:eek:

i ended up pulling the white wire from the speedo sensor (signal wire?) all the way back to a connector at the side of the main fuse box, from there it goes into the car but in the form of a purple wire... and that purple wire has been hacked into at some point, i removed the remainder of the connecter tonight!:crazy: why would anyone want to tap into this? knowing that might help me with the fault i guess.

now, is there a wire from the speedo back to the ecu? i dont see how else it would be connected
 

·
Registered
Joined
·
3 Posts
Re: Renault Clio 2 - Speedo Not Working

Im having this problem to on my v reg clio. iv been told it can be expensive to fix. it could need a whole new dash or its a problem in the gear box. take your car to an auto electrician and the will put it on a diagnostic check. it could be a lose wire or a fault pin. which could be cheap to replace. iv been told it can be a host of things.
 
1 - 20 of 33 Posts
Top