Independent Renault Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
So, I have had a black box fitted to my Clio and since then, it has been giving me some dashboard warning lights;

It has shown the following (all at separate times and they also go on, then off quickly afterwards)

Service light AND ABS light
Service light AND airbag light

Then not only that, the fog lamp indicator on the dashboard also came on the other day when indicating right, I was slowing and in 1st gear at a closed junction and when I was indicating the fog lamp indicator was really dim but noticeably lit up and flashing in time with the indicators, what could this be?

Could it be a case of checking all the fuses and re-seating them all? Also, how would I check to see if a fuse has blown? How can you tell?

Thank you for all the advice and the time taken to read my post. Hopefully somebody can assist me! :) Stay safe all.
 

·
Registered
Joined
·
260 Posts
So, I have had a black box fitted to my Clio and since then, it has been giving me some dashboard warning lights;

It has shown the following (all at separate times and they also go on, then off quickly afterwards)

Service light AND ABS light
Service light AND airbag light

Then not only that, the fog lamp indicator on the dashboard also came on the other day when indicating right, I was slowing and in 1st gear at a closed junction and when I was indicating the fog lamp indicator was really dim but noticeably lit up and flashing in time with the indicators, what could this be?

Could it be a case of checking all the fuses and re-seating them all? Also, how would I check to see if a fuse has blown? How can you tell?

Thank you for all the advice and the time taken to read my post. Hopefully somebody can assist me! :) Stay safe all.
The installer for your black box may have installed the wires in the wrong fuse slots. It has happened in the past with multiple black box installers.
 
1 - 3 of 3 Posts
Top