Independent Renault Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I am glad that I have found this site, and am hoping that someone can point me in the right direction. I have a problem with the heating system, as in during the winter the heater takes ages before any warm air starts coming through, and even when it does, it is not particularly warm at all. On the other hand, the air con does not seem to be doing anything at all during warmer weather and even at it's coldest setting, there is no difference in the air temperature coming out of the vents. When the air con button is pushed, the engine speed changes a little, indicating that the air con wants to work. I have had the system re gassed and there are no leaks. The air con worked ok 3 years ago when I got the car, but it has got steadily less effective. I have had a lot of water dropping on my feet in the past, and had suspected that I may have a matrix problem, however the leaking has now stopped, and has got me thinking that if the matrix is blocked, then maybe this is why it has stopped leaking. I seem to be going on a bit, so maybe someone out there can give me some ideas on what I could be checking for, thanks Dave
 

·
Premium Member
Joined
·
43,291 Posts
Hi Davsar - Has your vehicle a pollen filter and if so has it ben changed. The lack oh heat could be down to the engine thermostat being faulty (jammed open). It's highly unlikely a leaking heater matrix would seal itself - has anyone ever put radweld into the system.:)
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Thanks Chris, please could you advise me on the procedure to do this flushing activity. What do I disconnect and what do I need to remove from the vehicle etc. cheers Dave
 
1 - 4 of 4 Posts
Top