Independent Renault Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
bought this 4 days ago its got a fault that says fault in fuel injection system took it to local place they did one hell of a service to it said it just needed a service and sensors cleaning got it home tokk for a spin and it did it again
fault comes on and i loose all power like as if its starved of fuel if i turn it of then restart it behaves till it comes up with the fault again any ideas guys as i cant afford more costly hourly rates
 

·
Premium Member
Joined
·
40,429 Posts
The first thing I'd do is get it to a decent independant garage and get them to check the fault codes.This should give you more of an idea as to where the problem is.

There are many different things that can cause your problem,so it's best to try and eliminate some to make the diagnosis easier and more accurate.:)

Edit;If you bought it from a dealer,then get it back to them and get them to sort it.:)
 

·
Registered
Joined
·
24 Posts
Discussion Starter #3
sad story is i bought private the place i took it put it on a computor and was ep or eg somthing open or short circuit and also a turbo sensor fault that he said was fixed
 

·
Registered
Joined
·
24 Posts
Discussion Starter #5
i cant realy afford dealer prices and im stuck here are the falts showin on its computer any ideas where i start to remedy the fault
turbo preasure sensor consistancy between high preasure ajustment and sensor

airflow sensor open or short circuit

egr valve

air supply circuit

glow plug preheat faulty plug or open circuit

where do i start so i dont get this lack of power as if its starved of fuel or in limp mode any helpo be great thanks
 

·
Premium Member
Joined
·
2,861 Posts
i cant realy afford dealer prices and im stuck here are the falts showin on its computer any ideas where i start to remedy the fault
turbo preasure sensor consistancy between high preasure ajustment and sensor

airflow sensor open or short circuit

egr valve

air supply circuit

glow plug preheat faulty plug or open circuit

where do i start so i dont get this lack of power as if its starved of fuel or in limp mode any helpo be great thanks
Be very careful you don't have pending turbo failure that is known on both the 1.9 and 2.2 dci. A dirty EGR can cause the turbo to fail and basically kill the entire engine.

I really hope the private seller hasn't stitched you up...

Read this forum for more info

:(
 

·
Premium Member
Joined
·
644 Posts
there was a post on here with pics about cleaning the egr valve.its an easy job to do with the worst bit being getting the f**ker out its location
 

·
Premium Member
Joined
·
116 Posts
Hello Jaba,

If your still trying to find the EGR valve,

follow the inlet pipe to the engine- from the intercooler not airbox.

behind the inlet( black plastic butterfly valve secured with three bolts) you will see a silver canister, with a connector on the end secured with three 10mm bolts.

that is the EGR valve, take off the connector and remove the three bolts, it will be very tight but with a little effort, twisting and pulling it should come out.


best of luck

Murchin
 

·
Registered
Joined
·
4 Posts
I Had The Same Problem Many Months Ago...driving Along Overtaking An "artic" .... Suddenly, Loss Of Power ( As Though The Turbo Wasn't Running )
Narrowed It Down To The Intercooler...
Once Replaced It Was No Problem...
Hope This Helps
Wetbutsafe
 
1 - 14 of 14 Posts
Top