Independent Renault Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello everyone
First post so hoping you could help me thanks- I did a oil change on my Renault Megane coupe 1.6 today and couldn’t get the oil filter off so had to smash the oil filter up to get to inner ring and tap round with screwdriver & hammer!!! anyway I took battery poss off and all plug connections to alternator and oil pressure sender? But when refitting the grey multi plug just seemed to appear (don’t remember taking it off) does anybody know where this goes and also it looks like it’s disintegrated what is this part looks like a o ring is on it, does it go under intake manifold??? ? See pic-thanks
 

Attachments

·
Technical Supremo.
Scenic II, 2004, K4MW761, DPO
Joined
·
7,432 Posts
You broke the intake air temperature sensor ............. half of it is still plugged into the cable and the other half is now floating around inside the air intake - its lives on the front of the engine


I would suggest remove intake and the broken off plastic bit to prevent disaters before getting a new sensor
 

·
Premium Member
Grand Scenic 1.6 2007
Joined
·
6,411 Posts
I doubt that you are the first that this has happened to. In retrospect the correct tool is worth it.
The location of that filter does nothing to help. I know that it defied my collection of straps and wrenches and can't exactly remember what origami-limbo-dancing procedure I use except it's probably different each time.
The problem with the hammer approach is that as the red mist rises, everything in range becomes a nail.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Thanks for replies, I have sorted now what I think happened is the air temp sensor was removed with plug and pushed to side with all wires and it just disintegrated with getting moved and bashed !it was very brittle and I found bits of plastic and a small metal washer on the floor near oil drain tray!!!
So new sensor turned up today( £8) plugged in came up with anti pollution error cleared code all good :) thanks again
And yeah I think the oil filter tool is a good shout next time😡😡😡😡
 

·
Premium Member
Grand Scenic 1.6 2007
Joined
·
6,411 Posts
It's remarkable the gap between the advice we offer and what we actually do.
I did an oil and filter change yesterday. To get the strap on the filter I removed the stay bar between the alternator and the block, the main supply cable to the starter, fitted the strap thing crooked, tightened it with a long nose pliers all to get the five degrees of rotation available between the starter and the inlet manifold.
On the bright side the sump was well drained before I got back down there. :rolleyes:
 

·
Technical Supremo.
Scenic II, 2004, K4MW761, DPO
Joined
·
7,432 Posts
So @Brendan W seems to have the same service regime as myself :devilish:
 
1 - 6 of 6 Posts
Top