Independent Renault Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey guys i need some assistance with getting my megane ide soft top running. The cambelt snapped on my megane last week. I ripped the head off, replaced the valves and continued to build the head up. When it came round to doing the cambelt i realised this engine was clearly different to normal renault engines and that i had no info or timing equipment to set it up. I also noticed it had a cam sensor but wasnt sure wat it picked up off seen as though they were floating cams. I made a locking tool for the cams, fitted the pin to the crank and fitted the belt. However when it came round to starting it the engine woud fire once then cut out. I tried the usual locking/unlocking of the doors put the same thing happened. Looking back now i think i should of marked the pulleys but am struggling like mad to find a correct pic of the timing setup. I would appreciate any info on the timing setup or anyone who might have come across this before. ps incase anybody asks:
the engine has fuel pressure then loose it cutting feed to the injectors,
the camshaft sensor isnt faulty,
and the vehicle will continue to run on easy start,
(just incase anyone asks).
Thanks guys kab
 

·
Premium Member
Joined
·
431 Posts
hi m8 and welcome to the forums, if the car runs on easy start then the timming should be ok.
as to the cam sensor, it should run even if it was goosed so dont think its that or the pick up m8.

it sounds like eathier an electrical fault, eg immobilsier, fuel pump realy, earths ect.

it does sound like an immobilsier fault tbh, do you get a flashing red light between the rev counter and spedo, or does it stay a constant red when cranking the engine?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
hey bud thanks for the reply. To be honest i dont think its immobiliser related. The red light goes out when attempting to start and in addition to that the immobiliser should also cut feed to the injectors so the fact that it runs on easy start illiminates that. Im starting to think about the high pressure fuel pump at the end of the camshaft. This pump runs at 100bar si its imperative the timing is bang on but like i said earlier i cant find any literature on this engine. My search continues :(
 
1 - 3 of 3 Posts
Top