Independent Renault Forums banner

1 - 4 of 4 Posts

·
Premium Member
Joined
·
794 Posts
Discussion Starter #1
Picked up my first Safrane this evening.

MIGHTY impressive car in every way, can't believe I haven't had one sooner!

Now, the voice synthesizer says there is a "system malfunction". That's a bit of a vague statement. There's no warning lights on and the car is driving perfectly. Any ideas?
 

·
Premium Member
Joined
·
102 Posts
When it says this, is it when you start the car? - If so I suspect your fuel filter is in need of replacing and to avoid it, when you turn on the ignition, before hitting the starter, leave it 5 seconds for the fuel rail to pressurise. If you listen carefully you can hear the injectors rattling away and priming the engine.

If its not when you start the car then you need to give more information about when it happens so that I can try to help.
 

·
Premium Member
Joined
·
794 Posts
Discussion Starter #3
Thank you. I attached my fault code reader. I didn't think it would bring up anything as there were no faults on the dash. But it did, O2 sensor circuit malfunction. Cleared the fault and it hasn't come back!
 

·
Premium Member
Joined
·
102 Posts
Disconnecting the battery also tends to clear faults like that too.

I had the "Automatic transmission operating in safety mode" message the other day after having half the engine bay in bits. I'd forgotten to reconnect a couple of bits and the message wouldn't clear (it had obviously flagged up the parts not working as a fault). Disconnected the battery, waited 30 seconds to a minute, reconnected, gone :d

They're simple-complex cars.. scary for some people but most things are pretty easy to work around once you've got to know the car a bit.
 
1 - 4 of 4 Posts
Top