Independent Renault Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Renault Trafic 1.9 Diesel spluttering

Anyone tell me why my Trafic on low revs splutters and glow plug light shows on dashboard - have changed fuel filter and no different
 

·
Registered
Joined
·
18 Posts
Re: Renault Trafic 1.9 Diesel spluttering

hi. iv got the same problem with my own renault trafic 1.9, got it put on computer and it coming boost pressure sensor awaiting it at mo, it could be your maff sensor are the boost pressuer sensor take pipe off pressure sensor to see if it blocked mine was full of oil cleaned it but still the same, so awaiting pressure to see will that help?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Re: Renault Trafic 1.9 Diesel spluttering

could you tell me where the pressure sensor is please? I will then take off the pipe and see if like yours it is full of oil. Also my glow light comes on intermittently as well
 

·
Registered
Joined
·
18 Posts
Re: Renault Trafic 1.9 Diesel spluttering

my light on 2 if you dont get it sorted put it on computer, when you open bonnet it at rite hand side it a small back thing wif one pipe coming out of it and got elec switch pluged in it, hope this helps the descripyion not good lol hope u find it??
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
Re: Renault Trafic 1.9 Diesel spluttering

Not yet will try at weekend as van at home buit fingers crossed the damn thing works
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Got no power at all no in my Trafic - air filter changed no difference, glow light goes on and off when it feels like it had enough now - had every sensor possible changed and still no better - please, any ideas thanks:crazy:
 

·
Registered
Joined
·
1 Posts
Hi, I'm having the same problem problem on my Trafic.
I have noticed that the pressure converter valve making a funny noise. The buzzing noise starts about 10 seconds after I start the engine.

The problem comes and goes.

Thanks Erik
 

·
Registered
Joined
·
49 Posts
There is a boost pressure solenoid and a boost pressure sensor. If the sensor is faulty, the solenoid will buzz. You need to get the sensor changed (single vaccuum hose and elec clip going into it)

If that doesnt work, or try this first, check the turbo inlet pipe just after the MAF sensor for signs of wearing through. The airbox doesnt sit right and allows the pipe to rub away against the inlet manifold. fresh air gets sucked in AFTER the maf sensor and gives a dodgy reading and will shut the van down by putting her into limp mode.

Also try - under the expansion tank on the passenger side of the engine bay, 10mm bolt out, move exp tank over, lift lift off fuse box, two multi plug connectors near the wing. Take them apart and clean the connections in there. A big blue one and a smaller black one, give em a clean if poss and a squirt. Moisture gets in there and gives dodgy readings and bad connections.

Had all of these problems with mine (2002 trafic 1.9cdi), all been cured with a tube of silicone and a can of WD40!!
 
1 - 9 of 9 Posts
Top