Independent Renault Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi, I have a 57 reg Scenic II with 12k miles. Out of the blue, the front passenger electric window has stopped working. There is no sound... nothing. I have checked and swapped the fuses to no avail.
It was working one minute, and half an hour later, it was dead.
Any ideas?
Thanks in advance
Mark
 
G

·
It could be the switch, but regulator faults are quite common.

It might be worth a call to RCS to see if they will cover the cost of the repair even tho the car is out of warranty.....it's not unheard of for the regulators, although they will insist that it is diagnosed at a dealer, and they will only cover the cost if this turns out to be the cause

Failing that the units are available online much cheaper than they are through Renault
 

·
Registered
Joined
·
2 Posts
hi mark, I had same problem with my 54 plate scenic on a rear door window working one minute then nothing off either switch,was told about the problem of when it rains etc the water gets inside the door and drains out through the drain at the bottom of door(bad design if you ask me) therefore the regulator motor gets damp and stops working. On advise I tried the easy option first took the window switch off the offending door, ( 2 minute job) if you look into the little hole where the switch unit came from you may need a torch cos its dark in there, you can just see the black motor on the regulator, get a tin of wd 40 with the straw in the nozzle and soak as much of it as possible and leave it overnight keep fingers crossed and try it next day, thats wot I did and low and behold it worked fine and has done ever since, just try it before you go thro the messing of taking door panels off, or any big expense cost me £2 for wd40 and literally 20 mins of my time. Good luck, Steve
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top