Independent Renault Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hi I took my secenic II 04 diesel to a roll on carwash today and as I parked for the hoover everything went mad. Automatic Parking Brake stayed on, all the dash lights are on, check air bag, low oil pressure, service, Triangle P , check parking brake. All these come on repeatedly. Also cant use indicators or turn off lights or wipers or engine. Had to stall it to stop it. HELP ME PLEASE!!!!!!!
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
Oh Sh Only brought the car 2 weeks ago. I know it sounds stupid but can these dry out or ?. Surely I can have a car wash without that any reason why/how this would happen?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
Yes I managed to get it started and drove home with the wipers going and using the old fashioned hand signals for indicators. But when I got into my drive the car would not stop, so I had to stall it. I have just taken the battery off to reset everthing and hope things dry out. Will be up at 4.00am to put back on and see what happens. but any other helptonight would be very welcome.
 

·
Premium Member
Joined
·
803 Posts
Hi. It sounds like you have water in the UPC. It's a box of fuses beide your battery with loads of wiring connectors going into it. If you have the battery out already it shouldn't take you long to take it out and let it dry. You will need a T30 for the UPC cover and a T40 to take to battery box out. I would also spray WD40 or similar into the wiring connectors to remove any moisture from there.

HTH
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
ALL FIXED YIPEE 2 DAYS OF PURE STRESS
Dried out UPC box again overnight and removed every fuse,relay,connector gave everything a spray with pocket rocket. Car still did not start so jump started it took a few attemps, now everything is working fine. Oh except for the electric windows drivers side wont go down.
 

·
Premium Member
Joined
·
117 Posts
hi very comom ..dry out and it will work again ...also check glow plug light on dash ..if its ok then car will start ..if there is no glow plug light the the brown loom plug..in the fuse box is no conecting ..try moving the brown loom see if it starts...i there still in no glowlight then the brown loom is not conectng ..

the fault def her with the brown loom..orange wire on brown loom put 12v to it ..should start ....if not then a new fuse box needed or sec/hand on

hope this helps david
 

·
Registered
Joined
·
7 Posts
I've also had electronics problems with a Scenic II (not as bad as yours - rear lights not working and instrument panel backlights not working). Renault dealer also suggested that the UPC may be water-damaged. We park this car in a driveway with a tree nearby, and in autumn leaves clog the water outlets at the base of the front windscreen, which is probably why water got into the UPC, and could explain why a car wash caused the same for you.
 

·
Premium Member
Joined
·
2,637 Posts
I don't think he's been active since the post above- it looks like it was his last.
I wouldn't hold my breath waiting for a reply. You could try sending him a pm, then at least if he logs into the site a popup should alert him to your post.
 
1 - 13 of 13 Posts
Top