Independent Renault Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hi, I removed the rear seat from my scenic to clean them then reinstalled the next day now I’m gettting a warning on the dash in relation to the seat belts. Is there some reset procedure or have I not fitted the seats properly? Thanks in advance...
 

·
Super Moderator Technical Supremo Platinum Member
Joined
·
21,502 Posts
There are sensors in the seats to tell if someone is sitting on them.
Seat belt warning operates if they are without belts being latched.

I suspect sensors are triggered.
How were seats cleaned ?
 

·
Premium Member
Joined
·
6,849 Posts
The belt clip is the usual suspect, wires going into it tend to break and give false signal of the belt being unfastened.
 

·
Super Moderator Technical Supremo Platinum Member
Joined
·
21,502 Posts
The belt clip is the usual suspect, wires going into it tend to break and give false signal of the belt being unfastened.
Would agree normally but....
May be misreading OP but I'm reading it that the warning is on all the time, without anyone in the seat???
Which makes seat belt sensor/wires irrelevant.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Sorry yes it’s on even without anyone in the seat. I cleaned the seats with a karacher carpet machine meant for cars. I thought there my be some process of reprogramming when then are resinstalled. Looks like I’ve caused another problem!
 

·
Super Moderator Technical Supremo Platinum Member
Joined
·
21,502 Posts
Sorry yes it’s on even without anyone in the seat. I cleaned the seats with a karacher carpet machine meant for cars. I thought there my be some process of reprogramming when then are resinstalled. Looks like I’ve caused another problem!
Water
And electrics ????

I am by no means certain that is the problem but very suspicious it may be.
Could just be water in the connections and needs a squirt of contact cleaner.

Does the warning go out if you plug in the belts ?

Edit
Quick look on ebay, this seems to be the sort of sensor.
https://www.ebay.co.uk/itm/2009-On-...762667?hash=item3f8f65f22b:g:sYIAAOSwKQ9aOMXV
No idea where it is in the seat but if you can locate, that connector would be a good place to start IMO.
 

·
Premium Member
Joined
·
6,849 Posts
May be misreading OP but I'm reading it that the warning is on all the time, without anyone in the seat???
Which makes seat belt sensor/wires irrelevant.
Not quite.
When the wires are broken the belt clip sends the signal that the belt was unfastened - regardless of lack of passenger or the belt being never fastened in the first place.

It looks like this: start up the engine, drive away, suddenly get a 'seat belt unfastened' warning.
 
1 - 7 of 7 Posts
Top