Independent Renault Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
just wondering if anyboby has any experience of a scienic mk 3 handbrake fault
ive got a mk3 with electronic handbrake and the r/n/s does not always release, some times it will come off after using the switch a couple of times or driving a short distance, the caliper seems fine when i give it power directly to the motor it operates in both direction without a problem and the piston is nice and free. the o/s is working as it should,it seems as if it is not supplied with voltage for long enough to wind off.
cheers
peter
 

·
Super Moderator Technical Supremo Platinum Member
Joined
·
24,201 Posts
Sounds as if it may be a poor connector or wire.
That the OS is working okay says that the system generally is okay and sending the right signals.
But not getting through
 

·
Registered
Joined
·
4 Posts
just wondering if anyboby has any experience of a scienic mk 3 handbrake fault
ive got a mk3 with electronic handbrake and the r/n/s does not always release, some times it will come off after using the switch a couple of times or driving a short distance, the caliper seems fine when i give it power directly to the motor it operates in both direction without a problem and the piston is nice and free. the o/s is working as it should,it seems as if it is not supplied with voltage for long enough to wind off.
cheers
peter
did you ever get this sorted? mine is doing the same and have tried caliper replacement and many other things!
 

·
Super fantastic Mod Technical Supremo Nice Guy
Joined
·
41,025 Posts
there is someone who has had the same problem
he changed the handbrake switch..

its within the last month on here
 

·
Registered
Joined
·
4 Posts
thanks for the reply our2012 - i have checked the handbrake switch microswitches and they are all fine and is making good contact. I have also check the clutch switch.

I am going to recheck the caliper wiring and potentially look at replacing the epb module
 

·
Super fantastic Mod Technical Supremo Nice Guy
Joined
·
41,025 Posts
By applying hand brake a few times it works.????????
Are you sure about the hand brake switch being good
Would be double checking this, or plug going to this if mine
 

·
Registered
Joined
·
4 Posts
i took the switch unit out and tested the open / close continuity with a multi-meter. i gave it a bit of a clean and ensured when it was all back together that the main body was making good contact with the actual microswitches
 

·
Super fantastic Mod Technical Supremo Nice Guy
Joined
·
41,025 Posts
just with you putting all good/working if you apply handbrake a few times..

And with someone giving same problems as you, after changing lots of parts.
He then plumped for handbrake switch and cured it
 

·
Registered
Joined
·
4 Posts
Hi - just to add to repeat use of the switch to get it working - When the rear passenger caliper doesn't release i have to turn the engine off then on again to retry. It doesnt always work the second time either. Its not a repeated action that gets it working
 
1 - 9 of 9 Posts
Top