Independent Renault Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter · #1 ·
What had happened here it's on a 2003 1.2 16v clio and what do I need to do to put it right it's had new springs shocks etc ias it's a mot fail and mot is due on 20/09/21 plus I need to be able to use the car to get to a funeral
 

Attachments

·
Premium Member
Clio Mk IV 1.5 dCi MediaNav S/S 2013
Joined
·
2,877 Posts
I am sorry. Your post is a bit jumbled. Could you please ask your question again. It’s not clear what you are asking? You say it has HAD new springs. What exactly is/are the fault/s?
 

·
Registered
Joined
·
55 Posts
Discussion Starter · #3 ·
I am sorry. Your post is a bit jumbled. Could you please ask your question again. It’s not clear what you are asking? You say it has HAD new springs. What exactly is/are the fault/s?
Sorry I forgot to put up the photo it's on now
 

·
Super mod..
Joined
·
30,096 Posts
What had happened here it's on a 2003 1.2 16v clio and what do I need to do to put it right it's had new springs shocks etc ias it's a mot fail and mot is due on 20/09/21 plus I need to be able to use the car to get to a funeral
Its not 100% wrong Mark.. turn your steering wheel to see if the gap reduces when you are cornering.. you also say that new springs and shocks etc fitted and in many cases after market parts can make the situation worse and I would always recommend genuine mounts bearings and springs.. if you head over to cliosport its a hot topic plus the have a guides section to show you how to sort it..as you are a mk2 owner you should always join a forum that is dedicated to the Mk2 clio because there will always be a larger wealth of knowledge from many many owners on there on all topics..
 

·
Premium Member
Joined
·
1,503 Posts
o.k there is NO WAY that the shock absorber is new , as the threads sticking through are way too rusty. i.m guessing and not sure on clio setup (but VW's do the same) you will need top mount that sits on top coil spring cup , a top mount bearing and top hat (the bit with wavey rubber round it) these all know to wear / shrink / compress or deform causing gaps (another problem is people misassemble the nuts /cups/ bearings etc) but as phil said the clio forum will have picture guides and work arounds.
 
  • Like
Reactions: LvR and Phil48

·
Super mod..
Joined
·
30,096 Posts
o.k there is NO WAY that the shock absorber is new , as the threads sticking through are way too rusty. i.m guessing and not sure on clio setup (but VW's do the same) you will need top mount that sits on top coil spring cup , a top mount bearing and top hat (the bit with wavey rubber round it) these all know to wear / shrink / compress or deform causing gaps (another problem is people misassemble the nuts /cups/ bearings etc) but as phil said the clio forum will have picture guides and work arounds.
Sorry to say we never seem to get the full and correct info from Mark and this is a recurring theme.. without the full and truthful info how does he expect us to help..

Also Mark you do have a terrible habit of reposting the same info when a mod deletes a post.. same post again and then its deleted again in more than one section [ trolling ].. so a warning here continue in the same old way and your membership might get deleted.. we can only take so much that causes us continual monitoring and deletion of posts ..its just unnecessary work for us when there are other things to do and others to help..
 

·
Registered
Joined
·
55 Posts
Discussion Starter · #7 ·
o.k there is NO WAY that the shock absorber is new , as the threads sticking through are way too rusty. i.m guessing and not sure on clio setup (but VW's do the same) you will need top mount that sits on top coil spring cup , a top mount bearing and top hat (the bit with wavey rubber round it) these all know to wear / shrink / compress or deform causing gaps (another problem is people misassemble the nuts /cups/ bearings etc) but as phil said the clio forum will have picture guides and work arounds.
they are new as i put them on last year its copper slip not rust it may just need a new top mount
 
1 - 7 of 7 Posts
Top