Independent Renault Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi guys,I’ve just purchased a 2010 Clio 1.6 Initiale T-Tom VVT,I bought it from my mother in law so I have the last 3 years history on it,I’ve had it 2 weeks and I am now having issues with the trip computer display,it goes from really bright to almost unreadable,never know what it’s going to be like until I start the engine.
Over the last 4 days I’ve had no display at all,just an orange glow,I took It to a local garage who took the fuse out for the display and held the start button for a few minutes,the display came back again (although faint,could still be read ),after driving for a few miles the display changed to really bright and kept switching between bright and dim.....please,if anyone has any idea on why this is happening and how to fix I would very much appreciate it,thanks in advance
 

·
Technical Supremo, Platinum, I let the Dogs out
Joined
·
7,226 Posts
I dont know if you have the same as my Modus but the bottom left hand corner of the clock display is a button that if you repeatedly push it goes round in brightness circles, up to very bright then to nearly black and back up again, if you do check that button is free to move as it may be stuck in
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I dont know if you have the same as my Modus but the bottom left hand corner of the clock display is a button that if you repeatedly push it goes round in brightness circles, up to very bright then to nearly black and back up again, if you do check that button is free to move as it may be stuck in
Thank you,I’ve adjusted the wheel and it’s not that,the rest of the dash is ok,it’s just the trip computer display,I changed the fuse and was fine for a day,really bright and now it’s gone back to being faint again,might have to be a trip to Renault at some point


Sent from my iPhone using Tapatalk
 

·
Technical Supremo, Platinum, I let the Dogs out
Joined
·
7,226 Posts
it might also be the bulbs themselves, i have to tap my aircon control panel to get all the lights on every so often, maybe they are a bit gunged up back there and need cleaning/replacing
 
1 - 4 of 4 Posts
Top