Independent Renault Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi All

Hoping for a bit of advice on my daughters 61 plate Twingo Piaz. She is learning to drive so not being used very often, had some issues with battery being drained so have had to charge etc, but started OK after last being charged. Car has only done 45K

On startup the engine is revving between idle and I guess 3,000 rpm (no rev counter so guess) by itself, up and down very rapid approx (as fast as you could rev up then down) and pressing the accelerator has no effect. I have tried disconnecting the battery to try and reset ECU but with no success, a break down guy tried connecting his diagnostics tool, but said he could not connect, but all he wanted to do was tow to a garage so not sure if the truth, but if so I guess maybe ECU related. Any help or point in a direction would be appreciated. I have tried searching this and other forums but without finding much.

I have a short video in MP4 format so you can hear engine and also see a couple of lights on the dash (service spanner and rectangular box with waveline through the middle), but cannot upload so have posted on Youtube link below

https://youtu.be/KKEciinEbwI

PS I only have basic knowledge of cars, before you get to tecky with me, but willy to have ago or just find out if anyone has had before so can target where to get repaired

Thanks in advance
 

·
Super fantastic Mod Technical Supremo Nice Guy
Joined
·
39,821 Posts
Not a bloody clue..
That was the engine running, Did not sound like 3,000 RPM from the Video..

Lets see if we are reading this correctly.
You start the car, and it stays at high revs, but accelerator is doing nothing.
Or you start the car, high revs, the accelerator does nothing, but after a few minutes engine starts to idle, and still the accelerator does nothing.
That video to me sounds like your engine is at 1500 rpm in a limp mode.. ( Stage 1 and stage 2 limp modes Renault build into their ECU , yours seems like stage 2 , stage 1 allows you to drive, as such, )
This is Set by the ECU to stop any damage to the engine, now this could be Throttle body, or Accelerator pedal ,. Accelerator pedal or throttle body wiring on Track 2..

You need to get someone who can diagnose the car, or buy yourself an interface that can diagnose the car..
Depending what level of interface you go for will be a personal choice for you..
If with a laptop, then 40 £ interface will do nearly everything you will require..
( Wont allow fitting new Modules )
If a hand held scanner, then expect to pay £130+
But it needs to go on diagnostics, for you to have any chance with it..

With fault codes we can help, asking you to play parts darts when it could be a broken wire, and though you could repair the fault, stage 2 needs a diagnostics to clear the fault..
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Not a bloody clue..
That was the engine running, Did not sound like 3,000 RPM from the Video..

Lets see if we are reading this correctly.
You start the car, and it stays at high revs, but accelerator is doing nothing.
Or you start the car, high revs, the accelerator does nothing, but after a few minutes engine starts to idle, and still the accelerator does nothing.
That video to me sounds like your engine is at 1500 rpm in a limp mode.. ( Stage 1 and stage 2 limp modes Renault build into their ECU , yours seems like stage 2 , stage 1 allows you to drive, as such, )
This is Set by the ECU to stop any damage to the engine, now this could be Throttle body, or Accelerator pedal ,. Accelerator pedal or throttle body wiring on Track 2..

You need to get someone who can diagnose the car, or buy yourself an interface that can diagnose the car..
Depending what level of interface you go for will be a personal choice for you..
If with a laptop, then 40 £ interface will do nearly everything you will require..
( Wont allow fitting new Modules )
If a hand held scanner, then expect to pay £130+
But it needs to go on diagnostics, for you to have any chance with it..

With fault codes we can help, asking you to play parts darts when it could be a broken wire, and though you could repair the fault, stage 2 needs a diagnostics to clear the fault..


Hi Thank you for taking the time to reply, from start the car just starts this constant idle to higher revs cycle ( it sounds worse up close than the video, but maybe idle to 1500RPM, 2000RPM, ect) but it is constant does not settle down just keeps going up and down, with the accelerator pedal having no effect.

A code reader could be an option but the break down guy so say could not connect, but not sure I believe him
 

·
Registered
Joined
·
2 Posts
Hi , did you cure this issue by any chance , my son has a 2008 Twingo 1.2 16v that is doing the exact same thing , revs to 3000 rpm by itself on start up and bounces at that rev very much like an engine being held on its rev limiter , throttle pedal has no input at all .
Thanks , any advice or help be appreciated
 

·
Registered
Joined
·
2 Posts
H
Hi Thank you for taking the time to reply, from start the car just starts this constant idle to higher revs cycle ( it sounds worse up close than the video, but maybe idle to 1500RPM, 2000RPM, ect) but it is constant does not settle down just keeps going up and down, with the accelerator pedal having no effect.

A code reader could be an option but the break down guy so say could not connect, but not sure I believe him
Hi
Did you get this fixed. Mine is doing exactly the same. P0300 error code which is a random misfire . Any advice appreciated.
 
1 - 8 of 8 Posts
Top