Independent Renault Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
PLEASE HELP.i have just got a run arround renault 19 the problem is it doesnt start just clicks when you turn the ignition also there is a orange light looks like a heartbeat sign on the dash that keeps flashing please if you have any info let me know .also do you know if they were fitted with immobilizers. thanks
 

·
Premium Member
Joined
·
40,429 Posts
The clicking when trying to start is usually either a battery or starter motor problem.If both of these seem OK,then it could be an earth lead fault between the engine and body or between the body and the battery.

The factory fit immobiliser will either be on the keyblip,or there will be a seperate lock in the glovebox which requires a special key to activate.

The heartbeat type light is the engine management light which flashes to indicate that there is a problem in the system somewhere.

Will it run at all?
 
J

·
Guest
Joined
·
0 Posts
PLEASE HELP.i have just got a run arround renault 19 the problem is it doesnt start just clicks when you turn the ignition also there is a orange light looks like a heartbeat sign on the dash that keeps flashing please if you have any info let me know .also do you know if they were fitted with immobilizers. thanks
Welcome to the forum.....

My wife had a similar problem with an old clio a few years back.......

1)Check your battery connections are clean & secure
2)Try jump starting from another car (sometimes a low battery can cause the immobilizer to stop on)
3)Try a new battery in your key....

Failing that & other advise from here get yourself to a local garage & get a quote.......

If really stuck drop me a line......
 

·
Registered
Joined
·
2 Posts
Discussion Starter #6
thanks

thankyou i have had lots of info and alot keep coming back to starter motor . will check that .its just ive a gut feeling about the immobilizer because the cars not been started for 6 months and the car battery was dead.the fob one is fine. i know the car was running perfect 6 months ago . if i disarm the imbo the engine light stopsflashing and stays orange .but it just clicks from under the bonnet when i try and start it. thankyou all again.
 
1 - 6 of 6 Posts
Top